2
Vote

Could not find a part of the path 'C:\Users\<username>\AppData\Local\MAPILab_Ltd'

description

I ran into the following error in the latest version 2.1.0:
System.IO.DirectoryNotFoundException:
Could not find a part of the path 'C:\Users\Maxim\AppData\Local\MAPILab_Ltd'.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption)
at System.IO.DirectoryInfo.GetDirectories(String searchPattern, SearchOption searchOption)
at System.IO.DirectoryInfo.GetDirectories(String searchPattern)
at MAPILab.SharePoint.Explorer.MLMainForm.SearchInFirstVersions(DirectoryInfo directory)
at MAPILab.SharePoint.Explorer.MLMainForm.FirstTimeLoad()
at MAPILab.SharePoint.Explorer.MLMainForm.MLMainForm_Shown(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnShown(EventArgs e)
at System.Windows.Forms.Form.CallShownEvent()
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
 
After I created the missing floder 'MAPILab_Ltd' in 'C:\Users\<username>\AppData\Local\' the error didn't occur anymore.
The code breaks in SearchInFirstVersions(...).

comments

EugenMakarkhin wrote May 14, 2010 at 5:24 PM

We've already fix this bug, so you could download MAPILab Explorer for SharePoint ver 2.1.1. But in fact this message appears only once (when you started this application for the first time on computer and older versions are not used), so you could continue to use version 2.1.0.

Thanks for using our product.

Best regards,
Eugen Makarkhin

wrote May 14, 2010 at 5:25 PM

wrote Feb 13, 2013 at 11:23 PM